Elsasoft Forums
Elsasoft Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SqlSpec
 Feature requests
 Direct Linking to page
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

nameBrandon
Starting Member

6 Posts

Posted - Aug 28 2012 :  09:49:59 AM  Show Profile  Reply with Quote
I'd love to see (at least in the HTML format) an option or method to add a "Link to this page" link or icon. We're using the HTML docs in a SharePoint folder and copying the actual URL from the browser bar doesn't work (it sends you to the main page). We have to have people right-click the left-hand nav-bar links, and copy those links in order to share the specific page(s) with people.

An automated "click to send link to clipboard" a la, http://www.deluxeblogtips.com/2010/06/javascript-copy-to-clipboard.html would be awesome, but even a static link somewhere on the page saying "copy this" would be useful.

If I've somehow missed that I can do this now with templates, PLEASE let me know.



Jesse
Forum Admin

732 Posts

Posted - Aug 30 2012 :  6:47:15 PM  Show Profile  Reply with Quote
There's no way to do that now, you didn't miss anything. I'll have a look at what this would take.
Go to Top of Page

Jesse
Forum Admin

732 Posts

Posted - Aug 30 2012 :  9:37:15 PM  Show Profile  Reply with Quote
this is implemented in the current BETA. works only with the IE browser though. I put the link at the bottom of each page.

http://elsasoft.org/download.htm
Go to Top of Page

nameBrandon
Starting Member

6 Posts

Posted - Aug 31 2012 :  03:05:37 AM  Show Profile  Reply with Quote
Wow, thanks Jesse! I'll take a look at it! :)
Go to Top of Page

nameBrandon
Starting Member

6 Posts

Posted - Sep 06 2012 :  07:12:23 AM  Show Profile  Reply with Quote
quote:
Originally posted by Jesse

this is implemented in the current BETA. works only with the IE browser though. I put the link at the bottom of each page.

http://elsasoft.org/download.htm



Hey Jesse, sorry for the slow response, just got around to testing this now. I downloaded 6.7 beta (SQL 2012, even though I'm using it for Oracle), but don't see the link at the bottom of each HTML page.

I checked with IE (IE8 32-bit, Windows 7 32-bit) and Firefox, and didn't seem to see it in the HTML code either. Do I need to enable an option for this? I looked through the options, but didn't see it. Apologies if I missed something simple..

Brandon

Edited by - nameBrandon on Sep 06 2012 07:13:42 AM
Go to Top of Page

Jesse
Forum Admin

732 Posts

Posted - Sep 06 2012 :  11:20:54 AM  Show Profile  Reply with Quote
It should work, but I didn't test it for Oracle. I only checked it for MSSQL. I'll do that tonight and post back.

in the meantime, can you doublecheck what build are you using? It should be this:

Elsasoft SqlSpec 6.6.4626.37246
RETAIL - BETA - (SMO 2012 build)
build date: 2012-08-31 21:41:32

Just click the "go" button in UI with no connection strings specified and it will print this to the top of the progress window.

btw it looks like I forgot to bump the minor build number to 7. oops! i'll fix that in the next beta... :)
Go to Top of Page

nameBrandon
Starting Member

6 Posts

Posted - Sep 06 2012 :  12:44:03 PM  Show Profile  Reply with Quote
Elsasoft SqlSpec 6.6.4626.37246
RETAIL - BETA - (SMO 2012 build)
build date: 2012-08-31 23:41:32

so looks like the same version at least! :)
Go to Top of Page

Jesse
Forum Admin

732 Posts

Posted - Sep 07 2012 :  5:03:55 PM  Show Profile  Reply with Quote
Brandon,

by any chance are you specifying your own footer?

I put the link in the default footer that shows at the bottom of the page, so if you are specifying your own footer then you would not see the link.

I just tried the beta against an oracle db and the link did show up.

If you are using your own footer, then put this code in it somewhere to see the link:

<a href="javascript:void(0)" onclick="copyToClipboard(document.URL)">copy URL to clipboard (IE only)</a>

Jesse
Go to Top of Page

nameBrandon
Starting Member

6 Posts

Posted - Sep 07 2012 :  5:06:55 PM  Show Profile  Reply with Quote
quote:
Originally posted by Jesse

Brandon,

by any chance are you specifying your own footer?

I put the link in the default footer that shows at the bottom of the page, so if you are specifying your own footer then you would not see the link.

I just tried the beta against an oracle db and the link did show up.

If you are using your own footer, then put this code in it somewhere to see the link:

<a href="javascript:void(0)" onclick="copyToClipboard(document.URL)">copy URL to clipboard (IE only)</a>

Jesse




Yep, I'm using the template function to add a logo, and I probably did change or do something with the footer as well.. good call. :)

That's great, thanks for the code.. I'll probably move it to the header, thanks for making it so to easy customize!!!

Thanks again Jesse!

Brandon

Edited by - nameBrandon on Sep 07 2012 5:07:56 PM
Go to Top of Page

Jesse
Forum Admin

732 Posts

Posted - Sep 07 2012 :  5:08:09 PM  Show Profile  Reply with Quote
yes you can put it in the header also.
Go to Top of Page

nameBrandon
Starting Member

6 Posts

Posted - Sep 10 2012 :  05:58:25 AM  Show Profile  Reply with Quote
Works great Jesse! One small request.. Can you possibly turn that link off in .CHM generation? I'm not a CHM expert by any means, but I don't think the link is useful in that scenario. Not a huge deal, right now I'll just run SQLSpec twice.. once with the "url copy" link in my XML file, and then again, with it removed to get the clean CHM.

Thanks again!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Elsasoft Forums © Elsasoft LLC Go To Top Of Page
Snitz Forums 2000